top of page

BrightSPK Group

Public·32 members

Download Italian Movie Assassin's Creed IV: Black Flag

I have found the solution. I've found on the internet that the file uplay_install.manifest is causing this issue. 1) I looked to my backup from my old computer and fortunately had that file there. (This probably wonť help anyone without old files stored somewhere so live chat support is probably the only otion)2) I moved that file to the location where my AC black flag is stored. 3) In the uplay launcher I clicked locate the game. Files verification process will start.4) Files verification resulted with error but trying it for the second time did work. 5) After the files check - some files were missing so I just hit repair and after short time the missing files were downloaded. 6) After that i just tried to find the game via uplay launcher again and the game works now. Sadly there seems to be some problem with savegame files - they seem to be uncompatible now. I tried to restore that saves from my backup from old computer but they just don't show up in the game. So my game is working fine now but my 98 % sync save is probably gone...

Download italian movie Assassin's Creed IV: Black Flag


Welcome to the group! You can connect with other members, ge...
bottom of page